Like what you see?
Buy the book at the Focal Bookstore

Click here: http://focalbookstore.com/?isbn=9780240810317

Flash + After Effects
Chris Jackson
Flash Video (FLV) contains only rasterized images, not vector art. FLV files can be output directly from the Render Queue in After Effects. Render settings allow you to specify size, compression, and other output options. The FLV file can then be imported into Flash and published in a SWF file, which can be played by the Flash Player.

FLV files can be imported into Flash using ActionScript or Flash components. Components provide additional control of the visual interface that surrounds the imported video. You can also add graphic layers on top of the FLV file for composite effects.

An alternative to saving a composition as a SWF and FLV file is to export it as an image sequence. After Effects renders each image file with a numerically sequential naming convention. Upon importing the first image, Flash recognizes the naming convention and prompts you to import the entire sequence (Figure 3.5). Image sequences should be imported into a movie clip or graphic symbol. This allows for more flexibility in your Flash project.

![Image 00001](image00001.png) ![Image 00002](image00002.png) ![Image 00003](image00003.png) ![Image 00004](image00004.png) ![Image 00005](image00005.png)

**Figure 3.5:** After Effects can also export image sequences. It uses a sequential naming convention that Flash recognizes and allows you to import the entire sequence.

Both applications include many tools that allow you to easily composite graphics and video. The previous chapter discussed how to save Flash content to After Effects. File size was not a concern since the final output was video. The exercises in this chapter focus on exporting After Effects content to Flash, with an emphasis on maintaining a respectable file size for Web delivery.

### Exporting SWF Files

Let’s start by exporting compositions in After Effects to Flash SWF files. The goal is to export only vector objects to maintain a small file size. Why use After Effects to create Flash content? After Effects provides effects and animation presets that go way beyond the capabilities that Flash provides. It can be a real production time saver. The first exercise illustrates this by creating a complex text animation in After Effects by applying only one effect.
Exercise 1: Export Text Animation as Flash SWF

Text animation is rather difficult to do and time consuming in Flash. Each letter in the animation needs to be either ActionScript-driven or keyframed by hand in the Timeline. Either way, creating a complex text animation can be a real nightmare to a Flash designer. Here comes After Effects to the rescue!

Locate the Chapter_03 folder on the DVD. Copy this folder to your hard drive. The folder contains all the files needed to complete the chapter exercises.

After Effects provides many text animation presets that can be applied in one step. To see the text animation you will build, locate and play the Vertigo.swf file in the Completed folder inside the 01_SWF folder in Chapter_03 (Figure 3.6). When you finish this exercise you will be able to use the Text tool in After Effects to set up a text animation. You will export it as vectors for use in Flash.

Figure 3.6: Title sequence uses text animation created in After Effects.

1. Launch Adobe After Effects. It opens an empty project by default.

2. Select Composition > New Composition. You need to make the composition the same size as the Flash Stage you will be importing the text animation into. Make the following settings:
   - Composition Name: VertigoText
   - Width: 550
   - Height: 400
   - Pixel Aspect Ratio: Square Pixels
   - Frame Rate: 15
   - Duration: 0:00:03:00

   Click OK. The new composition opens with a black screen in the Composition panel. The Timeline opens a tab.
3. Click on the Type tool \( \text{T} \) at the top left of the screen. Go to the Comp Window and click inside to start typing. Type “Vertigo.” A text layer is automatically created in the composition and appears in the Timeline.

4. This can be any font or size that you want. Use the Character panel that opens by default when a text layer is created. Arial Black was used for this exercise. When you are done, center the text in the Comp Window (Figure 3.7).

5. Click on the Effects & Presets tab to the left of the Character tab. This brings that panel forward. Twirl open the Animation Presets folder. Twirl open the Text folder. This contains all the different preset folders of text animation. Twirl open the Animate In folder and select Center Spiral. This effect rotates in each letter from the center of the text layer to form the word.

6. To apply the preset, click and drag the effect from the Effects & Presets panel to the text in the Comp Window. A red marquee box appears indicating the selected layer. Release the mouse and you will notice that the text disappears. This is because the text is at the beginning stage of the animation preset.

7. Click on the RAM Preview button. The letters spiral in to form the word “Vertigo” (Figure 3.8). That was easy. Imagine trying to keyframe the spiral movement by hand in Flash. Save your project.

Figure 3.7: The Type tool automatically generates a text layer and opens the Character panel that allows you to change the font, size, leading, etc.

Figure 3.8: The text presets create complex text animation quickly and easily. When creating text, make sure you do not apply a stroke to it. This adds complexity to the animation and will increase the file size of the exported SWF file.
Wouldn’t it be nice to see a preview of each text animation preset before you applied it? You can. Go to the Effects & Presets panel and click on the menu arrow in the top right corner. Select Browse Presets from the popup menu. This opens Adobe Bridge. Double-click on the Text folder. Open any preset folder and single-click on the effect you want to see. A thumbnail preview of how the effect works appears in the Preview panel on the right side (Figure 3.9).

![Adobe Bridge](image)

**Figure 3.9:** Adobe Bridge allows you to preview all preset effects before you apply.

8. Press the **Home** key on the keyboard. This moves the Current Time Indicator to the beginning of the composition (00:00).

9. Select the **VERTIGO** text layer and press **S** on the keyboard to open the Scale property. Click on the stopwatch icon next to Scale to generate a keyframe.
   
   - Scrub through the numeric value and set it to **50%**.

![Scale property](image)

**Figure 3.10:** Scrub through the Scale value and set it to 50%.

10. Move the Current Time Indicator to where the text stops rotating (02:08).

11. Scrub through the Scale numeric value and set the text layer back to **100%**. A keyframe is automatically generated. Now the text will slowly scale up from 50% to 100% as it spirals in.

12. Click on the **RAM Preview** button. Save your project. It is time to export the composition as a Flash SWF file.
13. Select File > Export > Adobe Flash (SWF). This opens the Save File As dialog box. Save the SWF file to the 01_SWF folder in Chapter_03.

14. The SWF Settings dialog box appears. This is where you set up how the SWF will be exported. In the Images area, set After Effects to Ignore Unsupported Features. Anything that After Effects can’t export as a vector object will be ignored and will not show up in the final SWF file. Since text in After Effects is vector-based, you don’t need to worry about missing any letters.

![Figure 3.11: Set After Effects to ignore unsupported features when exporting vectors.](image)

15. There is no audio so leave that unchecked. Leave the rest of the settings as the default (unchecked). Click OK. After Effects creates a Flash SWF file.

16. Let’s move to Flash. Double-click on Vertigo.fla in the 01_SWF folder to open the file in Flash. It contains two layers: spiralAnimation and eye. The spiral animation is a movie clip that contains a spiral graphic symbol that rotates counter-clockwise creating a vortex tunnel effect.

![Figure 3.12: The Flash file contains two layers. The animation consists of a movie clip that contains a spiral graphic rotating counter-clockwise.](image)
17. Select Insert > New Symbol. Enter mcTextAnimation for the name and make sure that the type is set to Movie Clip. Click OK.

18. The Timeline for the new movie clip appears. Highlight the first blank keyframe and select File > Import > Import to Stage to open the Import dialog box. Choose the SWF file you created in After Effects. Click Open.

![Import](image1)

**Figure 3.13:** Import the SWF file created in After Effects into a movie clip in Flash.

19. When the SWF file is imported into the movie clip, it appears as a series of keyframes. Scrub through the Timeline to see the animation. Go to the Library. There is a graphic symbol for each letter in the text animation. Double-click on a graphic symbol and you will see that the letter form is a vector shape.

![Library](image2)

**Figure 3.14:** The imported SWF file appears as a series of keyframes in the Timeline and each letter appears as a graphic symbol in the Library.

20. Let’s add to this animation. First, insert a frame (F5) at frame 85 (Figure 3.15). This will hold the text on the screen long enough to read it.

![Timeline](image3)

**Figure 3.15:** Insert a frame (F5) at frame 85. This will extend the text’s time on the screen to allow the viewer to read it.
21. Next, create a spiral-out sequence using the exact same keyframes just in reverse order. To do this:
   ▶ Select the keyframes from frames 1 to 45.
   ▶ Select Edit > Timeline > Copy Frames.
   ▶ Click on the empty cell at frame 86. Select Edit > Timeline > Paste Frames.
   ▶ Highlight the pasted keyframes. Select Modify > Timeline > Reverse Frames.

   ![Figure 3.16: Create a spiral-out sequence by copying and pasting the frames at the end of the Timeline. Then reverse the frame sequence.](image)

22. Close out of the movie clip and return to the root Timeline. Click on the New Layer icon at the bottom of the Timeline panel. Rename the layer to text.

23. Click and drag the mcTextAnimation symbol from the Library to the Stage.

24. Go to the Properties panel and set the X and Y position to 0 (Figure 3.17). This aligns the registration point to the upper left corner of the Stage. Since the composition in After Effects was set to the same dimensions as the Flash Stage, the text will be positioned in the center of the Flash movie.

   ![Figure 3.17: Set the X and Y positions to 0 to center the text on the Stage.](image)

25. Save and publish your movie. The text spirals in and then out. You may want to add a “stop” action on the last frame of the text movie clip. Note that the final file size for the SWF file is around 8 KB. That is even smaller than the text animation SWF file exported from After Effects (9 KB). Flash does provide better compression than After Effects when exporting SWF files.

Creating and exporting complex text animation as a SWF file is rather easy to do in After Effects. This exercise introduced you to text layers and animation presets. There is much more that you can do with these. In fact, Chapter 5 devotes itself entirely to creating and animating text in After Effects.
Exercise 2: Export Illustrator Animation as Flash SWF

Let’s export one more SWF file from After Effects. For this exercise, you will use footage created in Adobe Illustrator to export a SWF file for the Flash Player. The final SWF file will only contain vector art, keeping the file size small.

1. Create a new project in Adobe After Effects.

2. Import the footage file. Double-click inside the Project panel. This opens the Import File dialog box. Locate the SpringLogo.ai file inside the 01_Footage folder in 01_SWF/Chapter_03. Select the file.

   **Figure 3.18:** Import the Adobe Illustrator file into the Project panel.

3. Before you import, choose Composition – Cropped Layers as the Import type in the Import dialog box. Each layer will import with their original dimensions. This will make it easier to animate in the Comp Window. Click OK.

4. Double-click on the SpringLogo composition in the Project panel to open it in the Timeline and Composition panels.

5. Select Composition > Composition Settings. Make sure the duration of the composition is set to five seconds (05:00). Click OK.

6. If you added more time to the original duration, you will need to zoom out the Timeline to view the entire composition. To do this, click and drag the Zoom slider at the bottom of the Timeline all the way to the left.

   **Figure 3.19:** Zoom out to view the entire composition’s Timeline.

7. Each layer’s colored bar needs to extend to the end of the Timeline. Re-trim the Out Point for each layer by clicking and dragging it to the end (Figure 3.20).
8. Let’s animate the ladybug. Go to the Comp Window and click and drag the ladybug to the lower left side of the Comp Window. This will be the starting point for its animation (Figure 3.21).

**Figure 3.20:** Re-trim each layer’s Out Point to the end of the Timeline.

**Figure 3.21:** Reposition the ladybug to the bottom left corner in the Comp Window.

**Motion Sketch**

In addition to manually setting keyframes, After Effects provides a Motion Sketch tool that records a motion path as you draw in the Comp Window. This is another great time saver in terms of animation.

9. Select **Window > Motion Sketch**. This opens the Motion Sketch panel in the bottom right corner of the Workspace.

10. Set the Smoothing to **10**. This reduces the number of keyframes recorded and produces a much smoother motion path. The higher the number, the smoother the motion. Don’t set this value too high or the tool will not accurately preserve the motion path drawn. Ten is a good number to start with.
11. Make sure both checkboxes are checked for **Show Wireframe** and **Show Background**. This makes the drawing much easier to do, as you can see the layers you are working with.

12. Click on **Start Capture** to activate the tool. It doesn’t start recording keyframes until you click and drag a layer in the Comp Window.

![Motion Sketch settings control the smoothness of the motion path.](Image)

**Figure 3.22:** The Motion Sketch settings control the smoothness of the motion path.

13. The goal of this animation is to have the ladybug animate over the title and end at the top of the “i” in the word Spring. Click and drag the ladybug in the Comp Window. The Motion Sketch tool records the keyframes as you move the cursor. Release the mouse button when you are done. This stops the tool from recording.

![The Motion Sketch records keyframes for the motion path drawn.](Image)

**Figure 3.23:** The Motion Sketch records keyframes for the motion path drawn.

14. Click on the **RAM Preview** button. Save your project.
15. Let’s orient the ladybug to follow the path. Select Layer > Transform > Auto-Orient. In the Auto-Orientation dialog box, select the option Orient Along Path. Click OK.

![Auto-Orientation dialog box](image)

**Figure 3.24:** Orient the ladybug to follow along the path.

16. You can adjust the recorded motion path in the Comp Window and Timeline panel. Select the layer in the Timeline and press P on the keyboard to open the Position property. The recorded keyframes appear in the Timeline section.

![Timeline panel](image)

**Figure 3.25:** Open the Position property in the Timeline to view the recorded keyframes.

17. Click on the RAM Preview button. Save your project.

18. Now that the animation is done, it is time to export the composition. Select File > Export > Adobe Flash (SWF). This opens the Save File As dialog box. Save the SWF file to the 01_SWF folder in Chapter_03.

19. The SWF Settings dialog box appears. In the Images area, set After Effects to Ignore Unsupported Features. Since the footage is an Adobe Illustrator file and does not contain any gradients, all the layers will export as vectors.

20. Click OK. Locate the exported Flash SWF file. Double-click on it to play the animation in the Flash Player. Notice that After Effects also saves a report HTML file (SpringLogoR.html) within the same folder as the Flash SWF file. This file contains a link to the Flash SWF file and allows you to play the animation in a browser window. This completes the exercise.

To summarize, you can create vector animation directly in After Effects and export it as a Flash SWF file without using Flash at all. This exercise also introduced the Motion Sketch tool, which can save time on animating layers. Flash does not have a tool like this. In order to create a similar motion path, you would need to create a motion guide and attach a layer to it.