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OPTIMIZING
Your System for Photoshop

Tuning for Performance



This chapter goes beyond speeding up how you can work faster in

Photoshop to how to make Photoshop work faster on your computer. The

most obvious thing you can do to speed up the performance of Photoshop

is to buy the latest computer. Unfortunately, that is an expensive game

to play and not really a good solution. Computers improve performance

with each new model. However, new operating systems may add new

features at the expense of performance gains from the hardware.

Fortunately, you do not have to go to extremes to make Photoshop run

faster on the computer you already use.

Hardware
Computers are made up of many different pieces. Sometimes keeping up

with all the acronyms for the components can be puzzling. It can take a lot

of work to learn what the latest technology improvements are to the

components you do understand. All these pieces work together. Improving

one piece often leads to faster performance, yet improving a different

piece might be more suited for your work. It is useful to understand the

hardware components and where you can get the most benefit for your

performance costs.

64- Versus 32-Bit Architectures

In the past few years, both Macintosh and Windows computers have

improved the operating systems (and hardware) to support 64-bit

computing. Previously, the computers operated at 32 bit. These two

phrases—“32 bit” and “64 bit”—are really descriptions of numbers.

A system that supports 64-bit numbers can count higher than a system

that supports 32-bit numbers.

As computers work with bigger and bigger chunks of data, they must be

able to keep track of the data. Each piece of data has an address. That

address is a number. The higher that address number can be, the

more data a computer can work with. This idea affects things such as

how much random access memory (RAM) can be installed in your

computer. A 32-bit system cannot use as much memory as a 64-bit

system, even if the memory is installed in the computer. More RAM

means more data is loaded into the fast memory for use by applications

that can use that memory.

Does 64-bit computing run 32 times as fast or even faster? The short

answer is no. There is a cost for all this extra data being used. However,

the performance gains are very significant. The gains can easily be

twice as fast or even higher. The amount depends a lot on your computer

and what you are doing. The exact numbers are unknown in practice.

What is not in dispute, though, is that 64 bit is a performance

improvement.

If you can run Photoshop in 64 bit, then it is worth doing so. How do you

check? On Mac OS X, choose Photoshop>About Photoshop... from

the Photoshop menus. On Windows, choose Edit>About Photoshop...

from the menus. The application version number is shown below the

application name in the About box (see Figure 3.1). Next to that

number is the indicator of which architecture the application is using:

x64 is for the 64-bit architecture, and x32 is for the 32-bit

architecture.

FIGURE 3.1 The Photoshop CS5 About box showing the version number and

architecture number.
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That information is useful, but what if the x64 is not there? Which

versions support 64 bit? The answers are a little complicated because

of when the work was done for the various operating systems and

when the versions of Photoshop were released. Here’s a general

summary:

Operating System Photoshop 64-bit Support Added

Windows 7: 64-bit version Photoshop CS5

Windows Vista: 64-bit version Photoshop CS4

Macintosh OS X 10.5 and later Photoshop CS5

How to Run in 32-Bit

It is not enough for your computer hardware and operating system

to support 64-bit computing; the software must support it as well.

There are a lot of reasons why this takes time for the engineers at

all levels to implement 64-bit computing. The good news is that it has

been done for the operating systems and for Photoshop. Despite that,

other pieces that you may use also have to support 64 bit. You may use

plug-ins that are not 64-bit compatible for one reason or another.

If that is the case, that plug-in is not available in Photoshop while

running in 64-bit mode. So you have to run Photoshop in 32-bit mode

to use that plug-in.

OnWindows, both versions are installed for you. To run the 32-bit version,

just double-click the icon for that version of the application.

On Mac OS X, both versions are also installed for you. However, the

operating system hides this from you and offers a different way to select

which version is run. To switch the Mac OS X version to run in 32-bit

mode, follow these steps:

1. In the Finder, navigate to the Photoshop CS5 folder and click to

select the Photoshop application icon.

2. Choose File>Get Info... from the operating system menus. The Get

Info window opens, as shown in Figure 3.2.

3. Click to check the Open in 32 Bit Mode checkbox in the Get Info

window.

4. Close the Get Info window.

5. Run Photoshop normally. Choose Photoshop>About Photoshop...

to see the About box and check the version number and architecture

indicator.

If your plug-ins are only 32-bit compatible, they should show up in the

menus when you run Photoshop in 32-bit mode. If you find they are not

there, you should check the plug-in manufacturer’s website for the latest

information. Most plug-ins have been updated for 64 bit at this time.

Many companies offer the 64-bit versions as free updates.

FIGURE 3.2 The Get Info window for the Photoshop CS5 application.
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RAM: Your Computer’s Short-Term Memory

Random access memory, known as RAM, is the place where the computer

stores the data for files you have loaded and the applications that load

them. The more applications running, the more files opened, and the

larger the files in use, the more memory is needed by the computer.

Modern computers can handle overflow when it occurs. The computer

starts using the hard drive for temporary memory. It pages large chunks of

RAM to the hard drive. These pages of memory can be swapped between

the hard drive and RAM as needed. The problem is that the hard

drive is slow compared to the RAM. The more the computer just uses

the RAM, the faster everything runs.

One of the biggest increases in performance can come from increasing

the RAM in the computer. When you increase the memory, you see a

bigger jump in performance going from 1GB of RAM to 2GB than the

increase going from 24GB to 32GB. The sweet spot for cost versus

benefit depends on your computer and the type of work you do in

Photoshop. If you are editing large photographs and adding a lot of

masked layers to the image, then adding RAM helps. If you are

combining multiple large images into a single image, like with a

panorama, increasing RAM helps. If you are editing photos using Camera

Raw and then saving the result as a JPEG file, the benefit may not be

worth the price of the extra memory, depending on how much RAM

you already have.

What you can do without spending money on RAM is tune Photoshop for

the RAM you do have. You do this using the Performance panel in the

Photoshop preferences (see Figure 3.3).

In Photoshop, choose Photoshop>Preferences>Performance... from the

menus on the Mac or Edit>Preferences>Performance... on Windows.

TheMemory Usage section deals with the amount of available RAM that

Photoshop is set up to use. It is best to keep the range in the low 70 percent

range as suggested by Adobe. However, if you need a little extra, you can

adjust thisnumberhigher.Justbeaware thatdoingsocanaffect the restof the

computer, so do not gomuch higher. Do not change the amount bymore than

5 percent before testing the performance to see how the change is working

(or not).

You might be tempted to allocate 100 percent of the RAM to Photoshop. Resist
such big numbers. The operating system needs memory for the computer to
work correctly. What happens when an application uses too much RAM is that
the computer swaps a lot of those memory pages between the hard drive
and the RAM to accomplish even simple tasks. This swapping slows down the
whole system, which also slows down Photoshop.

Photoshop has a built-in efficiency gauge to help you tune its performance

(see Figure 3.4). This is an option for display at the bottom of document

windows.

The percentage displayed for Efficiency is how much of given operations

are done using the available RAM without using the scratch disk. As you

work on images, if you notice this number falling below 95 percent

regularly, then you should adjust the setting in the Performance

preferences. If you still cannot raise the Efficiency number, you should

consider buying more RAM for your computer.

FIGURE 3.3 The Performance preferences.
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When you are doing a lot of work in Photoshop, it may also help to not be

running too many other applications that use a lot of memory. Multiple

applications all using up pieces of your computer’s memory can make

everything run slower.

Hard Drives and Scratch Disks

As mentioned in the preceding section, the computer will use the hard drive

to page memory out of RAM when it needs to. Photoshop does something

similar. When you manipulate an image in Photoshop, it keeps a lot of data

around in case you need it or for other uses. Sometimes this might be to

quickly undo an operation or store history states. Sometimes Photoshop just

needs extra memory for the calculations needed when doing adjustments.

The term “scratch disk” is used to mean a hard drive just used for the

temporary paging of memory. The hard drive does not have to be empty for

it to be of use. Just using a large drive with lots of available space can be

helpful. Also helpful is if that drive is a fast hard drive. Numbers change

on hardware, but it is good to get hard drives that run at 7200rpm or

faster. There is no strict rule about such things, just suggestions.

In the Performance preferences, one of the sections is named Scratch

Disks (see Figure 3.5). This section shows the available hard drives by

name and their available disk space. Simply check or uncheck a drive to

use it for a scratch disk. Usually, you want to set the drive with the

most available space as a scratch disk. Scratch drives are used from the

top of the list to the bottom. To change the order of the list, click to

select the drive and then use the arrow buttons next to the list to change

the drive’s order in the list.

The speed of a hard drive also affects how fast a file is written to disk. If

you save a lot of large files, it may be worth the price to upgrade to

a faster drive (with more space) to save time when you’re writing so

many files.

Hard drives can become fragmented. As the drive writes data, then deletes

data, and then writes more, data can get written to many smaller places.

A document might be split into many parts written all over the drive,

just based on how the drive has been used. There are several applications

on both Macintosh and Windows computers to defragment drives. The

applications may even be installed with the operating system. It is worth

running these applications from time to time to defragment the drive and

speed up the performance of the operating system and Photoshop.

FIGURE 3.4 The Efficiency display option at the bottom of document windows.

FIGURE 3.5 Tuning the scratch disk preferences.
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CPU: The Processor

The CPU is the central processing unit of the computer. This is the main

computation piece of the computer. It processes most of the instructions

from the operating systems and applications. Often the speed of the

processor or how many of them are installed or how many cores contained

in each chip are the specifications advertised for new computers. All these

specs do affect the performance of Photoshop. The application can

take advantage of each of these improvements. It is hard to change

processors in a computer, though. Usually, it is when you are purchasing a

computer that you need to worry about the CPU. These days, what you

want to be sure of is that the processor can support a 64-bit architecture.

As time goes on, this is likely to be the only option available to you anyway.

For the most part, you do not need to worry about the processor.

GPU and Video Cards

A computer’s video card is the hardware piece that processes graphics for

display on the computer monitor. The term “GPU” means graphics

processing unit. On many computers, you can upgrade video cards, and

there are many options available. Why do you care?

Increasingly, the operating systems and applications like Photoshop are
taking advantage of the fact the video cards can do image manipulations
quickly. Many have built-in support for doing 3D calculations. There is power
on the video card that can be used for performance gains.

Having a fast video card or upgrading your existing card may noticeably

improve the performance of your work in Photoshop, especially if you are

doing a lot of 3D work. In general, you want a card with a lot of video-RAM

(VRAM). It is best to check directly with the Adobe documents related to

supported video cards.

You might notice that the machine running Photoshop in Figure 3.5 does

not have a video card that can be tuned for Photoshop. Not all machines

can. Those that can will have settings enabled in the Performance and

the 3D preference panels.

The GPU Settings section displays the make and model of the video card,

and if it can be tuned by Photoshop (see Figure 3.6). The Advanced

Settings... button brings up another dialog with more options (see

Figure 3.7). The Mode value is what you are most likely to change.

FIGURE 3.6 The GPU Settings in the Performance preferences.

FIGURE 3.7 The OpenGL Settings dialog.
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Basic is for the minimum use of 3D technology. Normal is for times when

you use features and calculations that take advantage of the GPU

processor. Advanced is for heavy-duty 3D work. The default setting is

Normal. Depending on the work you do with Photoshop, you should set

this value accordingly.

The 3D Preferences are available in the Preferences dialog like other

preference settings (see Figure 3.8).

The setting that is most important for performance is the VRAM setting.

Similar to the RAM setting in the Performance panel, the VRAM setting

allocates how much of the video RAM Photoshop can use for its

operations. The percentage value for VRAM can be safely set higher

than the RAM setting. Few other applications use the VRAM at the

same time as other applications. However, the operating system

always does use a piece of the VRAM. So again, do not set the

value to 100 percent. Numbers between 85 and 95 percent should

be fine.

If you start noticing strange drawing issues with the monitor, you

may want to turn off OpenGL Drawing to see whether the video card

is causing the issues. Be sure to restart Photoshop for these changes to

take effect. If turning off OpenGL drawing causes the problem to go

away, you should go to the manufacturer’s website to look for driver

updates for your specific video card. Having the latest driver for the video

card is a good way to ensure compatibility with Photoshop and to

have the latest version of OpenGL, the 3D technology used by most

video cards.

Operating System
There is little that you can realistically do to tune your operating system to

improve Photoshop performance. However, what you can do is keep your

operating system up-to-date. This does not mean that you should

always buy the latest release from Microsoft or Apple; just keep your

version of the operating system up-to-date. Updates can include

performance fixes in addition to bug fixes. You might be surprised how

small fixes canmake big differences in your work. There are no guarantees

with each update, but it is always good to have the latest fixes for your

version of the operating system.

Photoshop
Photoshop has several ways to tune performance beyond those directly

related to hardware. Although the hardware settings can make the biggest

difference to Photoshop’s performance, other settings and even your own

behaviors also can give big improvements. Many settings related to

performance are a push-me-pull-you type of process. Changing one

setting affects the overall performance and may undo, in a sense, the

improvements made by changes to other settings. Tuning for performance

is more art than science and varies depending on the work you do in

Photoshop. It is beneficial to know what your options are to help maximize

Photoshop’s performance for you.

FIGURE 3.8 The 3D Preferences.
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Number of History States

If you haven’t already, you may want to increase the number of

history states that Photoshop stores. The settings for history states are

located in the Performance panel of the Preferences dialog (see

Figure 3.9).

Why are history states part of the Performance preferences? The more

history states you store, the more memory (RAM and potentially scratch

disk) Photoshop will use. You can have Photoshop store up to 1000

history states. The rule of thumb for history states is the bigger your

documents are, the smaller number of history states you want to store. If

you’re doing layout work or web design, you may want to have hundreds of

history states. If you’re retouching giant multi-megapixel images, you’ll

probably want many fewer history states. Experiment to see what number

works best for you.

History Cache

Images in Photoshop are divided into tiles. These tiles are small pieces of

the overall image. This is done so that the adjustments made to an image

can be performed quickly over small chunks of data, instead of over the

entire image. Because there are times when the entire image is not

displayed, these tiles can be ordered so the changes are displayed quicker

if the tile is visible. Tiling is also done for the various zoom levels to make

the zoom quick and seamless.

The larger the image you are editing, the more tiles are needed to display

that image. It can be beneficial to increase the Cache Tile Size if you

frequently work on large images. If you work on smaller images, you want

the Cache Tile Size to be smaller.

Setting the Cache Level is similar to setting the Cache Tile Size. If you

work on large documents, you want to set this number higher. For smaller

documents, set this number lower.

Three buttons can help you keep all of this straight: Tall and Thin,Default,

andBig and Flat. Think of these buttons as presets for theHistory & Cache

preferences. Each is a suggestion for what the settings should be,

depending on the types of images you usually work with.

The point to keep in mind with all these settings is that they affect the

computer’s memory. The more history states you allow, the more memory

required to save the states, which affects how much RAM is used and how

much memory is paged out to the scratch disk. All these factors affect

performance.

Close Unused Files

As you might expect, the more images you have open in Photoshop, the

more memory is required to display them all. If you are done with

an image, close it. Fewer document windows means a faster Photoshop.

FIGURE 3.9 The History & Cache preferences.
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Clear Available Memory With Purge

Choose Edit>Purge to view your options for purging some items from

memory (see Figure 3.10).

Undo, the system clipboard, and history all use up memory. If you

frequently find you get “Out of Memory” messages from Photoshop, you

can choose one or more of these menu items to temporarily clear some

memory. None of these commands can be undone because they are all

related to undoing operations. After the memory is cleared, the data is

gone. Use this option as a last resort.

Run Photoshop Only

It may be more and more inconvenient these days to run only Photoshop

when working on your computer. Yet doing so is a way to free up

memory for use by Photoshop, which speeds up the application’s

performance. Other resources are also freed up in the operating

system, the video card, and the hard drive when other applications are

closed.

Keep Photoshop Up-to-Date

Keep your version of Photoshop updated, just like you do for the

operating system. Photoshop does not release “dot updates” very often,

but when it does, you should install the updates. Performance is a

major concern for the Photoshop team, so performance fixes do find their

way into updates.

The Adobe Camera Raw plug-in updates regularly, mostly to add support

for newer cameras. These updates do include fixes. If you are shooting

in the Raw file format of your camera, you should keep the plug-in

up-to-date.

To update your version of Photoshop and Adobe Camera Raw, choose
Help>Updates... from the Photoshop menus. If updates are available, the
Adobe Application Manager launches to show you the updates. The application
can download and install any updates for you.

Don’t Overload Presets

Presets for brushes and styles generate previews for display in the

various panels and pickers in the application. Adobe provides several

extra sets for most of the presets, and others can be obtained on the

web and elsewhere. If you do not use any of these extra groups of

presets, do not load them or load them only when you need them. It

might also be a good idea to build your own custom sets that contain only

the presets you do use. The more presets loaded, the more previews that

need to be built, the more memory that gets used when you run

Photoshop.

FIGURE 3.10 The Purge menu commands.
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Note this does not mean that you should unload all the presets for each

feature. Just don’t overload the presets.

Turn Off Thumbnail Displays

A few panels, such as Layers,Channels, andPaths, show previews for their

content. When changes are made, these previews are updated, which

requires processing time. The previews themselves require memory for

storage.

Choose Panel Options from any of these panel’s menus to bring up the

Channels Panel Options dialog (see Figure 3.11) and change the size

of the thumbnail being drawn.

FIGURE 3.11 The Channels Panel Options dialog.
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